Описание встроенного языка системы 1С Предприятие


Принадлежит


Проверяет вхождение в список значений указанного значения.

Синтаксис:

Принадлежит(<Значение>)

Англоязычный синоним:

Belong

Параметры:

<Значение>

Значение, проверяемое на вхождение в список значений.

Возвращаемое значение:

Число: 1 — если проверяемое значение входит в список значений; 0 — если не входит.

Описание:

Метод Принадлежит проверяет вхождение в список значений заданного значения. Другими словами, оператор Список.Принадлежит(ВыбДок) проверяет, является ли значение ВыбДок подмножеством списка значений Список.

Если на принадлежность проверяется значение типа элемент справочника, то проверка выполняется с учетом его возможного вхождения в группы справочников, которые являются значениями списка значений.

Данный метод оптимизирует проверку принадлежности при массовых по­следовательных сравнениях, если между сравнениями сам список значений не меняется.

Пример:

Процедура ПроверитьКлиентов(СписокГруппКлиентов)

   // в качестве параметра Процедуры передается СписокЗначений

   // в котором записаны как элементы справочника Клиенты, так и

   // группы этого справочника

   Док = СоздатьОбъект("Документ.Накладная");

   Док.ВыбратьДокументы();

   Пока Док.ПолучитьДокумент() = 1 Цикл

      Если СписокГруппКлиентов.Принадлежит(Док.Клиент) = 1 Тогда

         Сообщить(Док.Клиент.Наименование + " " + Док);

      КонецЕсли;

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин