Описание встроенного языка системы 1С Предприятие


Пример использования объекта Таблица Значений


Пример:

Функция ВыбратьОплаты(ВыбДок)

   ТЗ = СоздатьОбъект("ТаблицаЗначений");

   ТЗ.НоваяКолонка("ДатаДок", "Дата", , , "Дата", 15);

   ТЗ.НоваяКолонка("Номер", "Строка", 20, , "Номер", 15);

   ТЗ.НоваяКолонка("Сумма", "Число", 18, 2, "Сумма", 20);

   ТЗ.НоваяКолонка("РасчетныйСчет", "Справочник.БанковскиеСчета", , ,

                   "Расч.счет", 30);

   ТЗ.НоваяКолонка("ПодчДок", "Документ", , , );

   ТЗ.ВидимостьКолонки("ПодчДок", 0);

   Док = СоздатьОбъект("Документ");

   Док.ВыбратьПодчиненныеДокументы(, , ВыбДок);

   Пока Док.ПолучитьДокумент() = 1 Цикл

      Если Док.Вид() = "ОплатаПоставщикам" Тогда

         ТЗ.НоваяСтрока();

         ТЗ.ДатаДок = Док.ДатаДок;

         ТЗ.Номер = Док.НомерДок;

         ТЗ.Сумма = Док.Итог("Сумма");

         ТЗ.РасчетныйСчет = Док.РасчетныйСчет;

         ТЗ.ПодчДок = Док.ТекущийДокумент();

      КонецЕсли;

   КонецЦикла;

   ВыбСтрока = 0;

   Если ТЗ.ВыбратьСтроку(ВыбСтрока, "Выберите оплату") = 1 Тогда

      Возврат ТЗ.ПолучитьЗначение(ВыбСтрока, "ПодчДок");

КонецФункции





Начало  Назад  Вперед



Книжный магазин