Описание встроенного языка системы 1С Предприятие



Предварительное описание процедур и функций


В тексте программного модуля допускается предварительное описание про­цедур и функций без их определения.

Пример:

  • фрагмента текста модуля, содержащий предварительное описание процеду­ры.
  • Процедура А(Парам1, Парам2) Далее

    Процедура Б()

       Перем АА, ББ;

       ...

       А(АА, ББ);

       ...

    КонецПроцедуры

    Процедура А(Парам1, Парам2)

       ...

    КонецПроцедуры

    В приведенном фрагменте видно, что обращение к процедуре А (из проце­дуры Б) предшествует по тексту ее фактическому определению, но перед про­цедурой Б имеется предварительное описание процедуры А.

    Процедура А(Парам1, Парам2) Далее

    На то, что это предварительное описание указывает наличие ключевого сло­ва Далее (англоязычный синоним — Forward), которое замещает в случае предварительного описания тело процедуры и ключевое слово КонецПроцедуры. Предварительное описание процедуры/функции может со­держаться в любом месте текста модуля, где допускается фактическое опреде­ление процедуры или функции, а сам заголовок процедуры/функции должен в точности соответствовать заголовку в фактическом определении, включая на­личие, если необходимо, ключевого слова Экспорт и имен формальных пара­метров.




    Содержание  Назад  Вперед