Описание встроенного языка системы 1С Предприятие


ПометкаУдаления


Прочитать флаг пометки удаления документа.

Синтаксис:

ПометкаУдаления()

Англоязычный синоним:

DeleteMark

Возвращаемое значение:

Число: 1 — если на документе стоит пометка удаления; 0 — если нет пометки удаления.

Описание:

Метод ПометкаУдаления позволяет прочитать значение пометки удаления документа.

Пример:

Процедура УсловноеУдаление(Докум)

   Док = СоздатьОбъект("Документ");

   Если Докум.Выбран() > 0 Тогда

      // позиционируем документ на переданном значении

      Док.НайтиДокумент(Докум);

      Если Док.Выбран() > 0 Тогда

         Если Вопрос("Удалять??? ", 1) = 1 Тогда

            Если Док.ПометкаУдаления() = 1 Тогда

               Предупреждение("Уже помечен на удаление!");

            Иначе

               // удаляем документ

               Док.Удалить(0);

            КонецЕсли;

         КонецЕсли;

      Иначе

         Предупреждение("Нечего удалять! ");

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: Удалить, СнятьПометкуУдаления




Начало  Назад  Вперед



Книжный магазин