Описание встроенного языка системы 1С Предприятие


Пометка


Пометить значение списка.

Синтаксис:

Пометка(<Позиция>, <Отметка>}

Англоязычный синоним:

Check

Параметры:

<Позиция> Номер позиции выбранного значения в списке.

<Отметка> Необязательный параметр. Число: 1 — установить отметку; 0 — снять отметку. Если данный пара­метр опущен, то отметка значения списка не из­меняется.

Возвращаемое значение:

Значение метки до выполнения метода. Число: 1 — отметка установлена; 0 _- отметка не установлена.

Описание:

Метод Пометка позволяет пометить указанную позицию списка значений.

Пример:

Функция ОтметитьДокумент(Список, ВыбДок)

   Для Н = 1 по Список.РазмерСписка() Цикл

      Док = Список.ПолучитьЗначение(Н);

      Если Док = ВыбДок Тогда

         Список.Пометка(Н, 1);

      КонецЕсли;

   КонецЦикла;

КонецФункции




Начало  Назад  Вперед



Книжный магазин