Описание встроенного языка системы 1С Предприятие


ПолучитьЗначение


Получить из выборки следующее периодическое значение.

Синтаксис:

ПолучитьЗначение()

Англоязычный синоним:

GetValue

Возвращаемое значение:

Число: 1 — если элемент выбран успешно, 0 — если элемент не выбран (от­сутствует).

Описание:

Метод ПолучитьЗначение выбирает периодическое значение в последова­тельности выборки, открытой перед этим при помощи метода ВыбратьЗначения или ВыбратьПоДокументу. Само полученное значение следует считывать из атрибута Значение. Дату этого значения можно считать из атрибута ДатаЗнач. Если значение периодического реквизита установлено документом, то этот документ можно получить при помощи метода ТекущийДокумент. Метод ТекущийОбъект позволит определить значение текущего элемента справочника, а метод ТекущийРеквизит — определить наименование текущего реквизита справочника.

Пример:

Процедура КурсыВалюты(КодВалюты)

   Вал = СоздатьОбъект("Справочник.Валюты");

   // Позиционируем созданный объект Вал по известному коду

   Вал.НайтиПоКоду(КодВалюты);

   Если Вал.Выбран() = 1 Тогда

      Доллар = Вал.ТекущийЭлемент();

   Иначе

      Предупреждение("Не найдена валюта!");

      Возврат;

   КонецЕсли;

   ПерВал = СоздатьОбъект("Периодический");

   ПерВал.ИспользоватьОбъект("Текущ_курс", Доллар);

   ПерВал.ОбратныйПорядок(1);

   ПерВал.ВыбратьЗначения();

   Пока ПерВал.ПолучитьЗначение() = 1 Цикл

      Сообщить("Курс на " + Строка(ПерВал.ДатаЗнач) + " = " + ПерВал.Значение);

   КонецЦикла;

КонецПроцедуры

См. также: ВыбратьЗначения, ВыбратьПоДокументу, ТекущийОбъект, ТекущийРеквизит, ТекущийДокумент




Начало  Назад  Вперед