Описание встроенного языка системы 1С Предприятие


ПолучитьСтроку


Полнить строку текста по номеру.

Синтаксис:

ПолучитьСтроку(<НомерСтроки>)

Англоязычный синоним:

GetLine

Параметры:

<НомерСтроки>

Числовое выражение — номер строки.

Возвращаемое значение:

Строковое значение — требуемая строка текста.

Описание:

Метод ПолучитьСтроку возвращает значение строки с номером <НомерСтроки>.

Пример:

Процедура Тест()

   Текст = СоздатьОбъект("Текст");

   Текст.Открыть(ИмяФайла);

   Если Текст.КоличествоСтрок() = 0 Тогда

      Предупреждение("Текст пустой!");

      Возврат;

   КонецЕсли;

   Для Ном = 1 по Текст.КоличествоСтрок() Цикл

      Стр = Текст.ПолучитьСтроку(Ном);

      Сообщить(Строка(Ном) + Стр);

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин