Описание встроенного языка системы 1С Предприятие


ПолучитьПредставление


Получить установки представления журнала расчетов — режим пред­ставления и отображаемый объект.

Синтаксис:

ПолучитьПредставление(<Режим>, <Объект>}

Англоязычный синоним:

GetPresentation

Параметры:

<Режим>

Переменная, в которую записывается числовое значение — текущий режим представления жур­нала расчетов.

<Объект>

Переменная, в которую записывается объект, за­писи которого отображаются. Если текущий ре­жим — «по одному документу» (см. ниже), этот параметр примет значение типа «документ», если режим устанавливаемого представления — «по одному объекту», этот параметр примет значение типа «элемент справочника».

Возвращаемое значение:

Число: 1, если представление успешно установлено; 0 — если представление по каким-либо причинам не установлено.

Описание:

Метод ПолучитьПредставление считывает текущие установки вывода за­писей в форме журнала расчетов. Параметр <Режим>, переданный по ссылке, в результате работы метода может принять следующие значения:

1. Записи по всем объектам расчета.

2.        Записи по одному объекту расчета.

3.        Записи по одному документу-основанию.

Параметр <Объект> получит значение того или иного типа, в зависимости от устанавливаемого режима. Если текущий режим — «по одному документу», этот параметр примет значение типа «документ», если режим устанавливаемого представления — «по одному объекту», этот параметр примет значение типа «элемент справочника».

Если текущий режим представления — просмотр записей по всем объектам расчета, параметр <Объект> не заполняется и его значение остается прежним.

Данный метод доступен только в контексте Модуля формы журнала расче­тов (см. «Виды программных модулей»).

Пример:

Перем СтРежим;

Перем СтОбъект;

Перем СменилиРежим;

Процедура ПоОдному(Сотрудник)

   // запомним предыдущие установки

   ПолучитьПредставление(СтРежим, СтОбъект);

   // Сменим режим

   СменилиРежим = УстановитьПредставление(2.Сотрудник);

КонецПроцедуры

Процедура Восстановить()

   Если СменилиРежим = 1 Тогда

      УстановитьПредставление(СтРежим, СтОбъект);

   КонецЕсли;

КонецПроцедуры

См. также: УстановитьПредставление, ГраницаПросмотра




Начало  Назад  Вперед



Книжный магазин