Описание встроенного языка системы 1С Предприятие


ПолучитьОтбор


Получить значение предварительно установленного отбора.

Синтаксис:

ПолучитьОтбор(<ИмяГрафыОтбора>, <ЗначениеОтбора>)

Англоязычный синоним:

GetSelection

Параметры:

<ИмяГрафыОтбора>

Переменная в которую будет возвращено строковое значение — наименование графы отбора, как она определена при конфигури­ровании.

<ЗначениеОтбора>

Переменная, в которую будет возвращено ранее установленное значение отбора.

Возвращаемое значение:

Число: 1 — если отбор был установлен и <ИмяГрафыОтбора> и <ЗначениеОтбора> заполнены установками сделанными ранее методом УстановитьОтбор; 0 — если отбор прежде не был установлен.

Описание:

Метод предназначен для получение текущих значений отбора, установлен­ных в форме журнала расчетов программным образом или интерактивно. Ме­тод заполняет параметры <ИмяГрафыОтбора> и <ЗначениеОтбора>, пере­данные по ссылке. Если отбор ранее не был установлен, метод возвращает 0, а значения переменных, переданных в качестве параметров, не изменяются.

Данный метод доступен только в контексте Модуля формы журнала расче­тов (см. «Виды программных модулей»).

Пример:

// модуль формы журнала расчетов

Перем ИмяОтбора;

Перем ЗначОтб;

Процедура ОтборПодразделения(Подразд)

   // ниже ИмяОтбора и ЗначениеОтбора будут заполнены

   // текущими значениями

   БылОтбор = ПолучитьОтбор(ИмяОтбора, ЗначОтб);

   Если БылОтбор = 1 Тогда

      Если ИмяОтбора = "Родитель" Тогда

         // снимем отбор

         УстановитьОтбор("");

      ИначеЕсли ИмяОтбора = "Подразделение" Тогда

         Сообщить("Было отобрано " + ЗначОтб.Наименование);

         УстановитьОтбор(ИмяОтбора, Подразд);

      КонецЕсли;

   КонецЕсли;

КонецПроцедуры

См. также: УстановитьОтбор, ЗакладкиОтбора




Начало  Назад  Вперед