Описание встроенного языка системы 1С Предприятие


ПолучитьДату


Получить дату календаря.

Синтаксис:

ПолучитьДату(<ДатаНачала>, <Количество>)

Англоязычный синоним:

GetDate

Параметры:

<ДатаНачала>

Дата начала периода, от которой будут отсчиты­ваться дни.

<Количество>

Количество дней, отсчитываемых от <ДатаНачала>.

Возвращаемое значение:

Значение типа «дата».

Описание:

Метод предназначен для определения даты, отстоящей от заданной даты на известное количество дней. В отличие от простого прибавления числа к дате, результатом которого является дата, смещенная на заданное количество дней, данный метод календаря производит определение итоговой даты, пропуская дни календаря, для которых задано нулевое значение. Это значит, например, что если в конфигурации присутствует календарь, представляющий собой гра­фик работы предприятия, то данный метод позволит легко определить дату, отстоящую от заданной на определенное количество «рабочих» дней (т. е. дней, для которых задано ненулевое числовое значение).

Пример:

Процедура ПровестиДокумент()

   Если Число(Окончание) = 0 Тогда

      // календарь

      Календ = Сотрудник.Категория.Получить(Начало).Календарь;

      // при расчете отпуска, запишем дату его окончания

      Календ = СоздатъОбъект("Календарь.Отпуск");

      Окончание = Календ.ПолучитьДату(Начало, КоличДней);

   КонецЕсли;

   Если Расчет <> ВидРасчета.ОтпускПоУходуЗаРебенком Тогда

      Если Окончание > ЖрнЗарплата.КонецТекущегоПериода() Тогда

         РасчетВперед(ГруппаРасчетов.ПересчДляОтпуска, Сотрудник,

                      ТекущийДокумент());

      КонецЕсли;

      ЖрнЗарплата.ВвестиРасчет(Сотрудник, Расчет, Начало, Окончание, 0);

   Иначе

      ЖрнЗарплата. ВвестиРасчет (Сотрудник, Расчет,

             Максимум(Начало, ЖрнЗарплата.НачалоТекущегоПериода()),

                  Минимум(Окончание, ЖрнЗарплата.КонецТекущегоПериода()), 0);

      Зарегистрировать(Контекст, ТекущийДокумент());

   КонецЕсли;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин