Описание встроенного языка системы 1С Предприятие


Получить


Прямое позиционирование на запись в выборке по конкретным зна­чениям группировок.

Синтаксис:

Получить(<ЗначениеГруппировки_1>, ..., <ЗначениеГруппировки_n>)

Англоязычный синоним:

Get

Параметры:

<ЗначениеГруппировки_n>

Выражение, содержащее значение n-ой группировки запроса.

Возвращаемое значение:

Число: 1 — если запись найдена, 0 — если нет.

Описание:

Метод Получить осуществляет прямое позиционирование на запись в вы­борке по конкретным значениям группировок.

Количество параметров метода зависит от количества группировок в запро­се. Можно пропускать значения одной или нескольких последних группировок, в этом случае метод позиционируется на запись, которая будет содержать ито­говые значения для указанных группировок. Пропускаемые при вызове метода последние значения группировок должны заменяться запятыми. Если при вы­зове метода опущены все параметры, то выборка позиционируется на самое начало временного набора данных, на строку итогов.

После выполнения метода Получить может осуществляться дальнейший обход выборки вызовами метода Группировка.

Пример:

// Текст запроса

Текст3апроса = "

| ...

|Группировка Должность;

|Группировка Категория;

| ...

|";

// Текст процедуры обработки запроса

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда

   Возврат;

КонецЕсли;

Если Запрос.Получить(ВыбДолжн, ВыбКатег) = 0 Тогда

   Если Запрос.Получить(ВыбДолжн, ) = 0 Тогда

      // ...

   КонецЕсли;

КонецЕсли;




Начало  Назад  Вперед



Книжный магазин