Описание встроенного языка системы 1С Предприятие


ПоказыватьУдаленные


Установить режим показа удаленных записей в базе.

Синтаксис:

ПоказыватьУдаленные(<Режим>)

Англоязычный синоним:

ShowDeleted

Параметры:

<Режим>

Необязательный параметр. Числовое выражение: 1 — установить режим показа удаленных записей в базе. 0 — снять режим.

Возвращаемое значение:

Текущее числовое значение режима показа удаленных записей в базе (на момент до исполнения метода).

Описание:

Метод ПоказыватьУдаленные позволяет определить и изменить режим показа удаленных записей в базе. В случае, если параметр не указан, изменения режима не происходит.

Пример:

Процедура ПоказатьНомераУдалЗап()

   РежПокУд = ДБФ.ПоказыватьУдаленные(1);

   ДБФ.Первая();

   Пока ДБФ.ВКонце() = 0 Цикл

      Если ДБФ.ЗаписьУдалена() = 1 Тогда

         Предупреждение("Номер удаленной записи — " +

                         Строка(ДБФ.НомерЗаписи()), 3);

      КонецЕсли;

      Если ДБФ.Следующая() = 0 Тогда

         Прервать;

      КонецЕсли;

   КонецЦикла;

   ДБФ.ПоказыватьУдаленные(РежПокУд);

КонецПроцедуры

См. также: Удалить, Восстановить




Начало  Назад  Вперед



Книжный магазин