Описание встроенного языка системы 1С Предприятие


Пока


Оператор выполнения цикла.

Синтаксис:

Пока <Логическое_выражение> Цикл

   //операторы;

КонецЦикла;

Англоязычный Синтаксис:

While <Логическое_выражение> Do

   //операторы;

EndDo;

Параметры:

<Логическое_выражение>

Логическое выражение.

Цикл

Операторы, следующие за ключевым сло­вом Цикл, выполняются, пока результа­том логического выражения является истина.

//операторы;

Исполняемый оператор или последова­тельность таких операторов.

КонецЦикла

Ключевое слово, которое завершает структуру оператора цикла.

Описание:

Оператор цикла Пока предназначен для циклического повторения операто­ров, находящиеся внутри конструкции Цикл ... КонецЦикла. Цикл выполняет­ся пока логическое выражение

— истина. Условие выполнения цикла все­гда проверяется вначале, перед выполнением цикла.

Пример:

Док = СоздатьОбъект("Документ.БригадныйНаряд");

// Будем просматривать документы в интервале дат

Док.ВыбратьДокументы('11.01.88', '11.01.99');

// Цикл по всем Документам

Пока (Док.ПолучитьДокумент() = 1) Цикл

   // отобразим Документ в строке состояния

   Состояние(Док.Вид() + " " + Док.НомерДок + " " + Док.ДатаДок);

   Док.ВыбратьСтроки();

   // вложенный цикл по всем строкам Документа

   Пока(Док.ПолучитьСтроку() > 0) Цикл

      Если Док.КодРабот = 104 Тогда

         Сообщить(" " + Док.НомерДок);

      КонецЕсли;

   КонецЦикла;

КонецЦикла;




Начало  Назад  Вперед



Книжный магазин