Описание встроенного языка системы 1С Предприятие

Профессиоанльный ремонт телевизора Panasonic на дому, выезд бесплатный.

ПериодДействия


Период действия записи журнала расчетов.

Синтаксис:

ПериодДействия

Англоязычный синоним:

EffectivePeriod

Описание:

Атрибут типа «период журнала расчетов» — период действия текущей запи­си журнала расчетов. Под периодом действия подразумевается тот расчетный период журнала, в который попадают ДатаНачала и ДатаОкончания дейст­вия записи журнала расчетов (акта расчета).

Атрибут ПериодДействия предназначен только для чтения.

Пример:

Процедура ПоПодр()

   Перем Запрос, ТекстЗапроса, Таб;

   //Создание объекта типа Запрос

   Запрос = СоздатьОбъект("Запрос");

   ТекстЗапроса = "//{{ЗАПРОС(ПоПодр)

   |Период с ДатаНач по ДатаКон;

   |Док = ЖурналРасчетов.Зарплата.ТекущийДокумент;

   |ПД = ЖурналРасчетов.Зарплата.ПериодДействия;

   |Подр = ЖурналРасчетов.Зарплата.Объект.МестоРаботы.Владелец;

   |Рез = ЖурналРасчетов.Зарплата.Результат;

   |Группировка ПД;

   |Группировка Подр без групп;

   |Функция Итог = Сумма(Рез);

   |"//}}ЗАПРОС

   // Если ошибка в запросе, то выход из процедуры

   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда

      Возврат;

   КонецЕсли;

   // Подготовка к заполнению выходных форм данными запроса

   Таб = СоздатьОбъект("Таблица");

   Таб.ИсходнаяТаблица("ПоПодр");

   // Заполнение полей "Заголовок"

   Таб.ВывестиСекцию("Заголовок");

   Пока Запрос.Группировка("ПД") = 1 Цикл

      // Заполнение полей ПД

      Таб.ВывестиСекцию("ПД");

      Сообщение(Запрос.ПД.Описатель);

      Пока Запрос.Группировка("Подр") = 1 Цикл

         // Заполнение полей Подр

         Таб.ВывестиСекцию("Подр");

      КонецЦикла;

   КонецЦикла;

   // Заполнение полей "Итого"

   Таб.ВывестиСекцию("Итого");

   // Вывод заполненной формы

   Таб.Опции(1, 0, 1, 0);

   Таб.Показать("ПоПодр", "");

КонецПроцедуры

См. также: ДатаНачала, ПериодДействия, ПериодРегистрации




Начало  Назад  Вперед



Книжный магазин