Описание встроенного языка системы 1С Предприятие


Перерасчет


Признак того, что запись является перерасчетом другой записи про­шлого периода.

Синтаксис:

Перерасчет

Англоязычный синоним:

Recalc

Описание:

Атрибут типа «число», принимает два значения: 1 — для записей-перерасчетов и 0 — для остальных записей.

Записи-перерасчеты вводятся в журнал расчетов при выполнении одного из методов журнала расчетов: ВвестиПерерасчет или ВвестиПерерасчетНаОсновании.

Атрибут Перерасчет предназначен только для чтения.

Пример:

ЖрнЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");

ЖрнЗарплата.ВыбратьПериодПоОбъекту(Сотрудник, ДатаОтчета);

Есть = 0;

Пока ЖрнЗарплата.ПолучитьЗапись() = 1 Цикл

   Если ЖрнЗарплата.Перерасчет = 0 Тогда

      Есть = 1;

      Пер = ЖрнЗарплата.ПервичнаяЗапись.ПериодРегистрации;

      Прервать;

   КонецЕсли;

КонецЦикла;

Если Есть = 1 Тогда

   Предупреждение("За истекший период проводились перерасчеты

          | прошлого периода " + Пер.Описатель);

   Возврат;

КонецЕсли;

// продолжим формирование документа

См. также: ПервичнаяЗапись




Начало  Назад  Вперед



Книжный магазин