Описание встроенного языка системы 1С Предприятие


Отчет по регистру с точностью до строки документа - часть 2


      // Отображаем значение измерения — ВидТоплива

      Таб.ВывестиСекцию("ВидТоплива");

      // запускаем вложенную группировку по документам,

      // которые производили движения Регистра

      Пока Запрос.Группировка(2) = 1 Цикл

         Док1 = Запрос.Док;

         // отфильтруем нужные нам документы

         Если НЕ(Док1.Вид() = "Продажа") Тогда

            Продолжить;

         КонецЕсли;

         // запускаем вложенную группировку по строкам

         // документа, связанным с движениями регистра

         Пока Запрос.Группировка(3) = 1 Цикл

            // Получаем в документе строку по найденному номеру

            Док1.ПолучитьСтрокуПоНомеру(Запрос.Ном);

            Таб.ВывестиСекцию("Строка");

         КонецЦикла;

      КонецЦикла;

   КонецЦикла;

   // Вывод заполненной формы

   Таб.Опции(О, О, 0, 0);

   Таб.ТолькоПросмотр(1);

   Таб.Показать("", "");

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин