Описание встроенного языка системы 1С Предприятие


Отчет по неходовым товарам - часть 2


      // но используем просто сам факт того, что товар попал во

      // временный набор данных Запроса.

      // Если товар есть в Запросе, то значит он упоминался в

      // каких то документах,

      // иначе — товар не пользуется спросом — неходовой.

      Если Запрос.Получить(Товар) = 1 Тогда

         Продолжить;

      КонецЕсли;

      // находим остатки неходового товара на складе

      Рег.СводныеОстатки(Товар, );

      ТекОстаток = Рег.ОстатокТовара;

      ТекСумма = Рег.БазоваяСтоимость;

      Если ТекОстаток = 0 Тогда

         Продолжить;

      КонецЕсли;

      Таб.ВывестиСекцию("Товар");

      ИтогоОстаток = ИтогоОстаток + ТекОстаток;

      ИтогоСумма = ИтогоСумма + ТекСумма;

   КонецЦикла;

   Таб.ВывестиСекцию("Итоги");

   Таб.ТолькоПросмотр(1);

   Таб.Опции(0, 0, 3, 0);

   Таб.Показать("Отчет о неходовых товарах", "");

КонецПроцедуры

ДатаКонца = РабочаяДата();

ДатаНачала = ДатаКонца — Константа.ПериодАнализа;




Начало  Назад  Вперед



Книжный магазин