Описание встроенного языка системы 1С Предприятие


ОсновнойЯзык


Определение основного языка конфигурации.

Синтаксис:

ОсновнойЯзык()

Англоязычный синоним:

GeneralLanguage

Возвращаемое значение:

Число 1 — если основной язык конфигурации — русский;

Число 0 — если основной язык конфигурации — английский.

Описание:

При помощи функции ОсновнойЯзык можно прочитать текущее значение основного языка конфигурации.

Замечание: Значение основного языка конфигурации задается в конфигура­торе (Метаданные-Глобалъный_модуль-Свойство-Задача-Основной язык).

Значение основного языка конфигурации используется системой в несколь­ких случаях, а именно, когда система передает в качестве параметра в предо­пределенную процедуру название объекта конфигурации. В этом случае назва­ние агрегатного типа данных передается либо в русском либо в английском написании — в зависимости от текущей установки основного языка конфигу­рации.

Пример:

*

В данном примере при записи периодического реквизита справочника (че­рез диалоговое окно «История») система передает в предопределенную процедуру строковое значение названия объекта. Нижеследующая проце­дура определяет, что введено значение курса валюты и сообщает об этом.

Процедура ПриЗаписиИстории(ИмяОбъекта, Объект, Значение, ДатаИстории)

   Если ОсновнойЯзык() = 1 Тогда

      СПР = "Справочник";

   Иначе

      СПР = "Reference";

   КонецЕсли;

   Если ИмяОбъекта = СПР + ".Валюты.Текущ_курс" Тогда

      Сообщить("Добавлено новое значение курса");

      Сообщить("Для валюты " + Объект.Наименование);

      Сообщить("На дату " + ДатаИстории);

      Сообщить("Установлено значение " + Значение);

   КонецЕсли;

КонецПроцедуры

См. также: ПриУдаленииИстории, ПриЗаписиИстории




Начало  Назад  Вперед



Книжный магазин