Описание встроенного языка системы 1С Предприятие


ОписательПериода


Возвращает строку-описатель периода.

Синтаксис:

ОписательПериода

Англоязычный синоним:

РеriodDescriptor

Описание:

Атрибут ОписательПериода является строковым представлением расчетного периода журнала расчетов. Тип формируемой строки различный для разной периодичности журнала расчетов. Например, для периода журналов с месячной периодичностью строка имеет вид "Январь 1997г", в случае квартальной перио­дичности журнала расчетов — "1 Квартал 1997г", а в случае недельной перио­дичности — "12.02.97 - 18.02.97".

Как правило, применяется при формировании отчетов.

Пример:

Процедура ВыводПоПериодам()

   Перем Запрос, ТекстЗапроса, Таб;

   Перем ДатаАкт;

   ЖЗ = СоздатьОбъект("ЖурналРасчетов.Зарплата");

   ДатаАкт = ЖЗ.НачалоТекущегоПериода();

   //Создание объекта типа Запрос

   Запрос = СоздатьОбъект("Запрос");

   ТекстЗапроса = "//{{ЗАПРОС(ВыводПоПериодам)

   |Период с ДатаАкт по ДатаАкт;

   |Сотр = ЖурналРасчетов.Зарплата.Объект;

   |Пер = ЖурналРасчетов.Зарплата.ПериодРегистрации;

   |Рез = ЖурналРасчетов.Зарплата.Результат;

   |Группировка Сотр упорядочить по Сотр.МестоРаботы без групп;

   |Группировка Пер;

   |Функция Сум = Сумма(Рез);

   |"//}}ЗАПРОС

   ;

   // Если ошибка в запросе, то выход из процедуры

   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда

      Возврат;

   КонецЕсли;

   Пока Запрос.Группировка("Сотр") = 1 Цикл

      Сообщить(Запрос.Сотр.Наименование);

      Пока Запрос.Группировка("Пер") = 1 Цикл

         Сообщить(Запрос.Пер.ОписательПериода + "-" + 3апрос.Сум);

      КонецЦикла;

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин