Описание встроенного языка системы 1С Предприятие


КоличествоСтрок


Возвратить количество строк текста.

Синтаксис:

КоличествоСтрок()

Англоязычный синоним:

LinesCnt

Возвращаемое значение:

Количество строк в тексте.

Описание:

Метод КоличествоСтрок возвращает количество строк в тексте.

Пример:

Процедура ЗагрузкаПродукцииПоКаталогу()

   Прод = СоздатьОбъект("Справочник.ГотоваяПродукция");

   Если ВыбГруппа.Выбран() = 0 Тогда

      Предупреждение("Ошибка! Не выбрана группа!");

      Возврат;

   ИначеЕсли ВыбГруппа.ЭтоГруппа() = 0 Тогда

      Предупреждение("Не выбрана группа! Загрузка в корень!");

   Иначе

      Тов.ИспользоватьРодителя(ВыбГруппа);

   КонецЕсли;

   Текст = СоздатьОбъект("Текст");

   Текст.Открыть(ИмяФайла);

   Если Текст.КоличествоСтрок() = 0 Тогда

      Предупреждение("Текст пустой!");

      Возврат;

   КонецЕсли;

   Для Ном = 1 По Текст.КоличествоСтрок() Цикл

      Стр = Текст.ПолучитьСтроку(Ном);

      Поле = 0;

      Пока СтрДлина(Стр) > 0 Цикл

         Поле = Поле + 1;

         Инд = Найти(Стр, "-");

         Если Инд > 0 Тогда

            Стр1 = Сред(Стр, 2, Инд - 3);

            Стр = Сред(Стр, Инд + 1);

         Иначе

            Стр1 = Сред(Стр, 2, (СтрДлина(Стр) - 2));

            Стр = "";

         КонецЕсли;

         Если Поле = 1 Тогда

            Код = Стр1;

         ИначеЕсли Поле = 2 Тогда

            Имя = Стр1;

         КонецЕсли;

      КонецЦикла;

      Прод.НоваяГруппа();

      Сообщить(Формат(Ном, "ЧЗ") + "-загрузка: " + Формат(Код, "45") + ":" + Имя);

      Прод.Наименование = Имя;

      Прод.Код = Число(Код);

      Прод.Записать();

      Сообщить(" — Загружен!");

   КонецЦикла;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин