Описание встроенного языка системы 1С Предприятие


Исправлена


Признак того, что запись исправлена вручную.

Синтаксис:

Исправлена

Англоязычный синоним:

Updated

Описание:

Атрибут типа «число», принимает два значения: 1 — для записей журнала расчетов, результат которых исправлен «вручную» и 0 — для остальных запи­сей.

Запись журнала расчетов становится исправленной при редактировании ре­зультата расчета непосредственно в журнале расчетов. Исправленные вручную записи не редактируются при очередном сеансе расчета, т. е. результат автома­тического расчета не заменяет результат ручного ввода. Это значит, что резуль­тат ручного редактирования «главнее» результата автоматического расчета.

Атрибут Исправлена предназначен только для чтения.

Пример:

// Проверим, не редактировали ли результаты ЖрнЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");

ЖрнЗарплата.ВыбратьЗаписиПоДокументу(ТекущийДокумент());

Счетчик = 0;

Пока ЖрнЗарплата.ПолучитьЗапись() = 1 Цикл

   Если ЖрнЗарплата.Исправлена = 1 Тогда

      Счетчик = Счетчик + 1;

   КонецЕсли;

КонецЦикла;

Если Счетчик <> 0 Тогда

   Сообщение("Исправленных записей — " + Счетчик);

КонецЕсли;

// продолжим формирование документа

См. также: Рассчитана, Фиксирована




Начало  Назад  Вперед



Книжный магазин