Описание встроенного языка системы 1С Предприятие


Если


Оператор условного выполнения.

Синтаксис:

Если <Логическое_выражение> Тогда

   //операторы;

[ИначеЕсли <Логическое_выражение> Тогда]

   //операторы;

[Иначе]

   //операторы;

КонецЕсли;

Англоязычный Синтаксис:

If <Логическое_выражение> Then

   //операторы;

[Elsif <Логическое_выражение> Then]

   //операторы;

[Else]

   //операторы;

Endlf;

Параметры:

<Логическое_выражение>

Логическое выражение.

Тогда

Операторы следующие за Тогда вы­полняются, если результатом логиче­ского выражения

в конструкции Если является истина.

//операторы

Исполняемый оператор или последова­тельность таких операторов.

ИначеЕсли

Логическое выражение, следующее за ключевым словом ИначеЕсли вычис­ляется только тогда, когда условия в Если и всех предшествующих ИначеЕсли оказались ложными. Опе­раторы следующие за конструкцией ИначеЕсли — Тогда выполняются, если результатом логического выраже­ния

в данном ИначеЕсли является ис­тина.

Иначе

Операторы, следующие за ключевым словом Иначе выполняются, если ре­зультаты логических выражений в кон­струкции Если и всех предшествующих конструкциях ИначеЕсли оказались ложными.

КонецЕсли

Ключевое слово, которое завершает структуру оператора условного выпол­нения.

Описание:

Оператор Если управляет выполнением программы, основываясь на ре­зультате одного или более логических выражений. Оператор может содер­жать любое количество групп операторов, возглавляемых конструкциями

ИначеЕсли — Тогда.

Пример:

Если (РабочаяДата() > '01.01.95') И (Сег = "Понедельник") Тогда

   Сообщить("Сегодня" + " " + Сег + " " + РабочаяДата());

КонецЕсли;




Начало  Назад  Вперед